Как установить Mikrotik OS на виртуальную машину Proxmox

27 января 2020  /  Маршрутизаторы программные

В данной статье я по шагам расскажу как установить Mikrotik OS на виртуальную машину Proxmox. В результате мы получим маршрутизатор Mikrotik работающий на x86 компьютере. Он может понадобиться для опытов, обучения или просто для различных тестов.

Где взять Mikrotik OS для виртуальных машин

Чтобы получить виртуальный Mikrotik нам понадобится Cloud Hosted Router (CHR) — это особая версия Mikrotik RouterOS разработанная специально для установки на PC на виртуальные машины. CHR предназначена для 64-битных платформ и может быть использована с большинством популярных гипервизоров таких как VMWare, Hyper-V, VirtualBox, KVM и другие.

Для того, чтобы в дальнейшем установить Mikrotik RouterOS CHR на сервер виртуализации Proxmox, нам необходимо посетить раздел загрузок официального сайта компании Mikrotik — https://mikrotik.com/download. И запомнить (скопировать) ссылку на образ в формате RAW.

Как установить Mikrotik OS на виртуальную машину Proxmox

Я в этой инструкции буду использовать версию 6.46.2 (Stable). И ссылка на нее выглядит так — https://download.mikrotik.com/routeros/6.46.2/chr-6.46.2.img.zip

Создаем виртуальную машину CHR

Все действия описанные ниже нужно проделать в консоли сервера Proxmox от имени root.

Первым делом посмотрим какие у нас есть виртуальные машины, чтобы выбрать незанятый вариант (номер).

# qm list
      VMID NAME                 STATUS     MEM(MB)    BOOTDISK(GB) PID
       100 VM-100               running    1024               8.00 1266
       101 MikrotiK             stopped    256                0.00 0

У меня уже есть две виртуальные машины, одна из которых ранее установленный виртуальный Микротик.

Скрипт создания виртуальной машины с Mikrotik OS

Этот скрипт создаст виртуальную машину с номером 102 на которую будет установлен Router OS CHR Mikrotik версии 6.46.2. Отредактируйте его под ваши задачи.

Выполнить следующие команды необходимо в консоли Proxmox:

cd /root
wget https://download2.mikrotik.com/routeros/6.46.2/chr-6.46.2.img.zip
unzip chr-6.46.2.img.zip
qemu-img convert -f raw -O qcow2 chr-6.46.2.img vm-102-disk-1.qcow2
cd /var/lib/vz/images/102
cp /root/vm-102-disk-1.qcow2 vm-102-disk-1.qcow2
qm create 102 \
  --name MikrotiK\
  --net0 virtio,bridge=vmbr0 \
  --bootdisk virtio0 \
  --ostype l26 \
  --memory 256 \
  --onboot no \
  --sockets 1 \
  --cores 1 \
  --virtio0 local:102/vm-102-disk-1.qcow2

После выполнения данных команд у вас появится новая виртуальная машина. Проверьте новый список в консоли Proxmox:

# qm list
      VMID NAME                 STATUS     MEM(MB)    BOOTDISK(GB) PID
       100 VM-100               running    1024               8.00 1266
       101 MikrotiK             stopped    256                0.00 0
       102 MikrotiK             stopped    256                0.00 0

или в веб-интерфейсе Proxmox:

Как установить Mikrotik OS на виртуальную машину Proxmox

Настройки сети виртуальной машины Mikrotik

Запустим необходимую нам виртуальную машину:

# qm start 101

И далее в консоли запущенно виртуальной машины (не сервера!) необходимо выполнить следующие команды:

/ip address add address=XXX.XXX.XXX.YYY/24 interface=ether1
/ip router add gateway=XXX.XXX.XXX.ZZZ

где вместо XXX, YYY и ZZZ используйте Ipv4 адреса для вашего виртуального маршрутизатора Микротик и шлюза по-умолчанию.

Как установить Mikrotik OS на виртуальную машину Proxmox

Для авторизации используйте логин admin и пустой пароль.

После этого можно запустить WinBox и приступить к настройке виртуального маршрутизатора. Скачать WinBox можно на официальном сайте Mikrotik в разделе загрузок — https://mikrotik.com/download

Как установить Mikrotik OS на виртуальную машину Proxmox

Благодарности

При написании статьи были использованы следующие источники:

  1. https://habr.com/ru/sandbox/115104/
  2. https://wiki.mikrotik.com/wiki/Manual:CHR_ProxMox_installation
 

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.

Мой лучший VDS/VPS хостинг
2020 © Технический блог
uptime узнать
Домен : reg.ru
Хостинг : adman.com
SQL - 38 | 0,163 сек. | 8.18 МБ